Friday, August 17, 2012

1 Install Oracle 10G on Windows 2008R2

Preconfigure:

  • Change the network card ip address to static IP.
  • Configure the firewall to allow the Oracle Port number

While trying to install the Oracle 10G on the Windows 2008 R2, you may encounter the error message “
Checking operating system version: must be 5.0, 5.1, 5.2 or 6.0.    Actual 6.1
                                      Failed
<<<<”

image

The 6.1 is the windows Kernel version which representing the Windows 7 and Windows 2008R2. type winver.exe will show you the current windows build.

image

NOTE: Hacking Oracle software is not recommended.

If you are sure this OS is compatible with Oracle, the easy way to get around this restriction is updating below files:

$ORACLE_SOFTWARE_PATH\database\install\oraparam.ini
$ORACLE_SOFTWARE_PATH\database\stage\prereq\db\refhost.xml
$ORACLE_SOFTWARE_PATH\database\stage\prereq\db_prereqs\db\refhost.xml

Replace 6.0 with 6.1 and re run the installer.

Example of the oraparam.ini as below:

[Certified Versions]
#You can customise error message shown for failure, provide value for CERTIFIED_VERSION_FAILURE_MESSAGE
Windows=5.0,5.1,5.2,6.1

[Windows-6.1-required]

image

After the installation , the Enterprise Manger ( DB Console service) fail to start up. I have spend lots of time for research without success. The only thing I have not try is to apply the path because one Oracle support post mention that the Root certificated has been expired which could cause the issue. http://zamantatari.blogspot.com/2011/08/document-titleenterprise-manager.html

1 comments:

  1. In reality, the vertical spread can be found inside a number of the beforehand discussed systems. Thanks for sharing about oas review.

    ReplyDelete

 

SQL Panda Copyright © 2011 - |- Template created by O Pregador - |- Powered by Blogger Templates